Fabric Latest Versions

Discord GitHub stars GitHub stars

Minecraft Version:

Note fabric-api version may not be the correct version for the given minecraft version. See the curseforge page.

build.gradle

dependencies {
    minecraft "com.mojang:minecraft:{minecraft_version}"
    mappings "net.fabricmc:yarn:{yarn_version}:v2"
    modImplementation "net.fabricmc:fabric-loader:{loader_version}"
            
    //Fabric api
    modImplementation "{fabric_maven}{fabric_version}"
}

gradle.properties (Example Mod)

minecraft_version={minecraft_version}
yarn_mappings={yarn_version}
loader_version={loader_version}

#Fabric api
fabric_version={fabric_version}


Mappings Migration

Mappings can be auto updated by using the following command. See the wiki page for more help.

gradlew migrateMappings --mappings "{yarn_version}"

Loom Version

The recommended loom version is 0.4-SNAPSHOT

When upgrading from loom 0.2.5 or lower make sure to take a look at the upgrade guide here


Want to help improve this page? Fork it on github